vBulletin LTS

РУС | ENG

vBulletin LTS - проект долгосрочной поддержки ("Long Time Support") по продлению жизненного цикла движков форумов vBulletin 3 и 4, которые официально больше не поддерживаются.

LTS обеспечивает для vBulletin:
  • Поддержку новых версий php
  • Поддержку новых версий баз данных
  • Обновления безопасности
  • Исправление ошибок
Кроме того, в рамках поекта долгосрочная поддержка LTS может быть предоставлена для сторонних плагинов (расширений), разработанных для vBulletin 3 и 4.

vBulletin 3 LTS

Текущая версия vBulletin LTS: 3.8.12 (работает на php 5.6-7.1, php 7.2-7.4)
Этот релиз предназначен для обновления последней официальной версии 3.8.11.
Новое в релизе 3.8.12 LTS:

  • Работает на версиях php 7.2-7.4 (php 5.6-7.1 также поддерживается)
  • Исправлены стандартные шаблоны для работы с новыми версиями php
  • Исправлены некоторые ошибки vBulletin

Следующая версия vBulletin LTS 3.8.13 (3.9.0) будет будет работать только на php 7.x-8.x. В этой версии, кроме поддержки php 8, исправлены различные старые ошибки vBulletin, не связанные с версией php.
Следите за разделом Новости чтобы быть в курсе.

vBulletin 4 LTS

Текущая версия vBulletin LTS: 4.2.6 (работает на php 5.6-7.1, php 7.2-7.4)
Этот релиз предназначен для обновления последней официальной версии 4.2.5.
Новое в релизе 4.2.6 LTS:

  • Работает на версиях php 7.2-7.4 (php 5.6-7.1 также поддерживается)
  • Исправлены стандартные шаблоны для работы с новыми версиями php
  • Исправлены некоторые ошибки vBulletin

Следующая версия vBulletin LTS 4.2.7 (4.3.0) будет будет работать только на php 7.x-8.x

Скачать

Пожалуйста прочитайте FAQ и напишите мне email.

FAQ

В. Можно ли здесь скачать последние официальные версии vBulletin 3.8.11 и 4.2.5?
О. Нет, я не распространяю официальные версии vBulletin. Я оказываю LTS поддержку для указанных версий форума.

В. Есть ли демо-версия форума vBulletin LTS?
О. Да.

В. Должна ли у меня быть лицензия на vBulletin чтобы использовать обновления и исправления LTS?
О. Я приветствую использование лицензионного программного обеспечения, но не могу проверить наличие у вас действующей лицензии на vBulletin.

В. Для каких версий vBulletin предоставляется поддержка LTS?
О. Поддержка LTS может быть предоставлена для последних официальных версий vBulletin 3 (3.8.11) и vBulletin 4 (4.2.5). Если вы используете одну из предыдущих версий, то вам нужно обновить форум до последней официальной версии. Поддержка LTS также может быть предоставлена для форумов, на которых уже установлены какие-то обновления последних официальных релизов.

В. Можно ли применить обновление LTS к форуму, на который уже установлено какое-то другое неофициальное обновление vBulletin?
О. В общем случае да, но нужно предварительно проверить совместимость LTS с вашим форумом.

В. Достаточно ли исправлений от LTS для работы моего форума на новых версиях php?
О. Да. В случае, если на вашем форуме установлены сторонние плагины для vBulletin и/или внесены изменения в стандартные шаблоны vBulletin, может потребоваться исправление сторонних плагинов или измененных шаблонов. Список установленных плагинов и изменененных стандартных шаблонов можно посмотреть в консоли администратора vBulletin.

В. Можно ли получить от LTS исправление шаблонов и сторонних плагинов моего форума, которые несовместимы с установленной версией php/базы данных?
О. Да.

В. Как вы делаете поддержку новых версий php для vBulletin LTS?
О. Я провожу тестирование всех функций форума (их очень много) под последней версией PHP, исправляю все выявленные ошибки и предупреждения всех уровней. Затем я выполняю регрессионное тестирование для проверки изменений.

В. Когда будет выпущена следующая версия vBulletin LTS?
О. Поддержка PHP 8 для vBulletin 3 и 4 это очень большие проекты. Разработка начата в декабре 2022 года, в настоящее время поддержка php 8 для vBulletin 3 находится на финишной стадии, следите за разделом Новости.

В. Как получить поддержку vBulletin LTS?
О. Напишите мне, указав адрес вашего форума. Ваш обратный адрес электронной почты должен относиться к тому же домену, что и ваш форум.

Обо мне

Я квалифицированный разработчик, имеющий 20-летний опыт работы с форумами vBulletin в качестве владельца, администратора и программиста. У меня холодная голова и прямые руки. Все изменения LTS выпускаются только после тщательного тестирования и отладки.

Контакты

Вы можете связаться со мной по электронной почте, но я обрабатываю запросы только от владельцев форумов. Ваш адрес электронной почты должен быть из того же домена, что и ваш форум. Например, если URL-адрес вашего форума http://myforum.com или http://myforum.com/forum, ваш обратный адрес электронной почты должен иметь вид something@myforum.com.


Этот сайт не имеет никакого отношения к компании "MH Sub I, LLC dba vBulletin", которой принадлежат все права на vBulletin®

Обновления vBulletin LTS предоставляется «как есть», без каких-либо гарантий, явных или подразумеваемых, включая, помимо прочего, гарантии коммерческой пригодности, пригодности для определенной цели и ненарушения прав. Ни при каких обстоятельствах авторы или обладатели авторским правом не несут ответственность за любые претензии, ущерб или иную ответственность, вне зависимости договора, возникающие из программного обеспечения или использования.